[klibc] arm: Enable CONFIG_ARM_EABI by default

Since Linux 4.14, the "new" system call ABI (CONFIG_AEABI) is enabled
by default when building for ARMv6/v7 processors.  The old system call
ABI can be enabled in parallel (CONFIG_OABI_COMPAT) but is disabled by
default.

When building a kernel for ARMv4/v5 processors, the default is to
enable only the old system call ABI.  However, the two distributions
I'm aware of that support these processors, Arch and Debian, configure
the kernel to support only the new system call ABI.

Therefore I think that it is better to assume the "new" system call
ABI by default.

Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
1 file changed