blob: 0f8501575bc161ad61ccf12ae4526ffb7baf8c65 [file] [log] [blame]
From ltsi-dev-bounces@lists.linuxfoundation.org Fri Feb 22 12:15:13 2013
From: Paul Gortmaker <paul.gortmaker@windriver.com>
Date: Fri, 22 Feb 2013 14:32:42 -0500
Subject: lttng: fix reference to obsolete RT Kconfig variable.
To: <ltsi-dev@lists.linuxfoundation.org>
Message-ID: <1361561562-5136-1-git-send-email-paul.gortmaker@windriver.com>
The preempt-rt patches no longer use CONFIG_PREEMPT_RT in
the 3.4 (and newer) versions. So even though LTSI doesn't
include RT, having this define present can lead to an easy
to overlook bug for anyone who does try to layer RT onto
the LTSI baseline.
Update it to use the currently used define name by RT.
Reported-by: Jim Somerville <Jim.Somerville@windriver.com>
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
---
[caused by LTSI patch patches.lttng/lttng-update-to-v2.0.1.patch]
drivers/staging/lttng/lttng-events.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/staging/lttng/lttng-events.c
+++ b/drivers/staging/lttng/lttng-events.c
@@ -51,7 +51,7 @@ int _lttng_session_metadata_statedump(st
void synchronize_trace(void)
{
synchronize_sched();
-#ifdef CONFIG_PREEMPT_RT
+#ifdef CONFIG_PREEMPT_RT_FULL
synchronize_rcu();
#endif
}