Enable pointer auth at EL2 and below

This patch disables EL3 traps for pointer auth functionality, such that
lower ELs can use it without requiring EL3 intervention.

We should check ID registers first, but this is good enough for testing.

Signed-off-by: Mark Rutland <mark.rutland@arm.com>
1 file changed