mb2q: Fix deprecated yaml.load() warnings by specifying Loader

Fix the following mb2q issue on startup:

  $ ./mb2q ./t.mbox
   ./mb2q:653: YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated,
   as the default Loader is unsafe. Please read https://msg.pyyaml.org/load for full
   details.
   cfg = yaml.load(open(os.path.expanduser(args.config)))

Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>

1 file changed
tree: 9c88947591cf022f2d6131f758233fc2a832fa28
  1. .gitignore
  2. COPYING
  3. Documentation/
  4. LICENSES/
  5. README.md
  6. mb2q
README.md

mb2q - Mailbox to quilt series converter

Install

It's recommended to generate the appropriate package for your system and install it via the package manager.

Usage

See Documentation and man pages