Released as 3.6.0
diff --git a/ChangeLog b/ChangeLog
index 0e01d61..c704572 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,45 @@
+2018-06-30  Martin Mares <mj@ucw.cz>
+
+	* Released as 3.6.0.
+
+	* BARs reported by the OS, but not set on the device itself are
+	  reliably marked with "[virtual]".
+
+	* Library: Introduced a generic mechanism of string properties. This
+	  avoids lots of special cases and makes ABI compatibility easier.
+
+	* On Linux systems with OpenFirmware, report corresponding device tree nodes
+	  as device properties.
+
+	* VPD decoder knows several non-standard extensions.
+
+	* When PCIe link speed is less than the maximum supported by the
+	  device, it is explicitly marked as "downgraded".
+
+	* Several new capabilities are not decoded yet, but at least their
+	  names are printed.
+
+	* The Null capability is easily decoded.
+
+	* Formatting of several capabilities was cleaned up.
+
+	* The VGA16 bit in the bridge control register is now supported.
+
+	* Added a port to SylixOS. Thanks to YuJian Gong for contribution.
+
+	* Added a port to DOS/DJGPP. Thanks to Rudolf Marek for contribution.
+
+	* The order in which back-ends are probed was decoupled from the
+	  internal back-end IDs. This helps, because new back-ends must have
+	  their ID allocated at the end to keep the ABI, but they might need
+	  to be proved earlier.
+
+	* The fbsd-device back-end should work again.
+
+	* Fixed a couple of bugs. Most notably, DeviceName was not printed.
+
+	* As usually, updated pci.ids to the current snapshot of the database.
+
 2017-11-17  Martin Mares <mj@ucw.cz>
 
 	* Released as 3.5.6.
diff --git a/Makefile b/Makefile
index 96fffca..f7ad2cc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,11 @@
 # Makefile for The PCI Utilities
-# (c) 1998--2017 Martin Mares <mj@ucw.cz>
+# (c) 1998--2018 Martin Mares <mj@ucw.cz>
 
 OPT=-O2
 CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
 
-VERSION=3.5.6
-DATE=2017-11-17
+VERSION=3.6.0
+DATE=2018-06-30
 
 # Host OS and release (override if you are cross-compiling)
 HOST=
diff --git a/README b/README
index 894c277..29815ba 100644
--- a/README
+++ b/README
@@ -1,6 +1,6 @@
 This package contains the PCI Utilities, version @VERSION@.
 
-Copyright (c) 1997--2017 Martin Mares <mj@ucw.cz>
+Copyright (c) 1997--2018 Martin Mares <mj@ucw.cz>
 
 All files in this package can be freely distributed and used according
 to the terms of the GNU General Public License, either version 2 or
diff --git a/lib/pci.h b/lib/pci.h
index 8cf9c4c..38d224d 100644
--- a/lib/pci.h
+++ b/lib/pci.h
@@ -16,7 +16,7 @@
 #include "header.h"
 #include "types.h"
 
-#define PCI_LIB_VERSION 0x030506
+#define PCI_LIB_VERSION 0x030600
 
 #ifndef PCI_ABI
 #define PCI_ABI